[Pacemaker] having problem with crm cib shadow

John McCabe john at johnmccabe.net
Fri May 17 07:22:57 EDT 2013

Looks like its due to the directory where the cib files are stored changing
between Pacemaker 1.1.7 and 1.1.8. (alluded to in this ticket -
http://savannah.nongnu.org/bugs/index.php?37760). The cib new does create
the shadow, but its looking in the wrong directory when it then tries to
list/work with that shadow.

Creating a symlink as follows lets the crm utility work with the shadow as
expected for some quick tests (tried a new, edit, commit on an existing

ln -s /var/lib/pacemaker/cib /var/lib/heartbeat/crm

Will raise at http://savannah.nongnu.org/bugs/?group=crmsh

On Fri, May 17, 2013 at 11:01 AM, John McCabe <john at johnmccabe.net> wrote:

> On Fri, May 17, 2013 at 8:43 AM, Lars Marowsky-Bree <lmb at suse.com> wrote:
>> On 2013-05-16T21:09:35, John McCabe <john at johnmccabe.net> wrote:
>> > Worth trying crm_shadow as described here -
>> > http://www.gossamer-threads.com/lists/linuxha/pacemaker/84969
>> >
>> > I had the same problem and took it as a sign that I should just move to
>> pcs
>> > (from the RHEL repo, not the latest source), which went pretty smoothly,
>> > only had a few problems with assigning parameters to resources.. but
>> that
>> > could easily be worked around using crm_resource.
>> So a single bug in the crm shell is a reason to move, while working
>> around "a few problems" isn't? I'm getting too old for this world ;-)
> Have been trying to stick with RH/CentOS supplied packages and since the
> issues I'd hit were all fixed upstream I was happy enough to proceed with
> pcs. (Meta Attr and Operation handling in the pcs resource create command
> weren't working properly in the 0.9.25-10.el6_4.1 package but are fixed in
> 0.9.41 on github. To stick with the current 0.9.25 I just created the
> resource without meta/ops using pcs and then added the meta/ops using
> crm_resource).
>> Have you reported the crm shell issue via bugzilla?
> It hadn't even crossed my mind at the time, my bad. I'll check out the
> latest source, compare the behaviour then raise a ticket.
>> Probably a permission problem on centos.
>> Regards,
>>     Lars
>> --
>> Architect Storage/HA
>> SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix
>> Imendörffer, HRB 21284 (AG Nürnberg)
>> "Experience is the name everyone gives to their mistakes." -- Oscar Wilde
>> _______________________________________________
>> Pacemaker mailing list: Pacemaker at oss.clusterlabs.org
>> http://oss.clusterlabs.org/mailman/listinfo/pacemaker
>> Project Home: http://www.clusterlabs.org
>> Getting started: http://www.clusterlabs.org/doc/Cluster_from_Scratch.pdf
>> Bugs: http://bugs.clusterlabs.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clusterlabs.org/pipermail/pacemaker/attachments/20130517/0f531dae/attachment-0003.html>

More information about the Pacemaker mailing list