[Pacemaker] Pacemaker 1.1.10 and pacemaker-remote

James Oakley jfunk at funktronics.ca
Thu Dec 5 20:56:55 EST 2013

On Thursday, December 5, 2013 11:51:01 AM "Lars Marowsky-Bree" <lmb at suse.com> wrote:
> > However, the nodes do not show up in crm status output as in the examples
> > in the documentation. I also tried creating a resource to run on a remote
> > node, but it said the node didn't exist.
> Right. Do they show up in crm_mon?


Last updated: Thu Dec  5 17:44:20 2013
Last change: Thu Dec  5 17:42:58 2013 by hacluster via crmd on hn0
Stack: corosync
Current DC: hn0 (1077857413) - partition with quorum
Version: 1.1.10+git20131204.93a37bf-93.1-1.1.10+git20131204.93a37bf
2 Nodes configured
7 Resources configured

Online: [ hn0 hn1 ]

 Resource Group: grp_db0
     fs_db0     (ocf::heartbeat:Filesystem):    Started hn0
     lxc_db0    (ocf::heartbeat:lxc):   Started hn0
 Resource Group: grp_db1
     fs_db1     (ocf::heartbeat:Filesystem):    Started hn1
     lxc_db1    (ocf::heartbeat:lxc):   Started hn1
 Resource Group: grp_squid
     ip_squid   (ocf::heartbeat:IPaddr2):       Started hn0
     squid      (ocf::heartbeat:Squid): Started hn0
dummy   (ocf::pacemaker:Dummy): Started hn1

The dummy resource is something I attempted to get running on the "db0" node, but I get this in crm:

WARNING: loc_dummy: referenced node db0 does not exist

> You can try upgrading to the packages from
> networking:ha-clustering:Factory from the openSUSE Build Service, which
> are more uptodate than 13.1 already.

I just tried that. No difference for remote-node, but crm has more pretty colours, and the templates are now shown as raw xml in "crm configure show".

> We also have a very quiet opensuse-ha mailing list for issues specific
> to packaging on openSUSE: http://lists.opensuse.org/opensuse-ha/ feel
> free to raise this over there too.

Quiet is why I tried here and not there. :-) I will have to subscribe to that.

James Oakley
jfunk at funktronics.ca

More information about the Pacemaker mailing list