[Pacemaker] How to flush the arp cache of a router?

Lars Ellenberg lars.ellenberg at linbit.com
Tue Jan 31 07:43:57 EST 2012

On Thu, Jan 26, 2012 at 01:05:07AM +0100, georg at riseup.net wrote:
> He all,
> I'm using Debian Stable and corosync/pacemaker/DRBD with Asterisk in a
> master/slave-setup.
> I get calls routed from my carrier to an ip in a private net. I'm using a
> Cisco 876 as the router.
> As the ressource agent for managing a virtual ip I'm using IpAddr2, which
> should do arp broadcast when bringing up the ip (as far as I read).
> However, in my case this doesn't work.
> I then had a look at SendArp, but read, that one shouldn't use this in
> conjunction with IpAddr2. Anyway, this didn't work also.
> In the end I tried to use arping, which works great, but I found no way to
> execute it from the cluster automatically. I tried to put it into a file
> and made this executable, and used lsb: to call it (which didn't work).
> Then I googled for hours to find out, how to call scripts from within crm,
> but had no success...
> Could someone point me into the right direction?

Did you tcpdump?
Does IPaddr2 send_arp actually work and send out the unsolicited arps it
is supposed to send?

Do you have any "IPaddr2.*: ERROR: Could not send gratuitous arps" in
your logs?

Maybe replacing the call to send_arp with calls to arping will do,
as I described in this thread:

: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

More information about the Pacemaker mailing list