[Pacemaker] Cannot Create Primitive in CRM Shell

Jake Smith jsmith at argotec.com
Mon Jan 9 13:16:22 EST 2012

> Date: Mon, 9 Jan 2012 16:37:58 +0100
> From: Florian Haas <florian at hastexo.com>
> To: The Pacemaker cluster resource manager
> 	<pacemaker at oss.clusterlabs.org>
> Subject: Re: [Pacemaker] Cannot Create Primitive in CRM Shell
> Message-ID:
> 	<CAPUexz9srHpeqbBFbY6sjk-q1vY2BYcSAmFp38tezCMM7s4kyA at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
> On Mon, Jan 9, 2012 at 4:10 PM, Andrew Martin <amartin at xes-inc.com>
> wrote:
> > Perhaps as a corollary problem I have noticed that I cannot seem to
> > start or
> > restart pacemaker:
> > # service pacemaker restart
> > Starting Pacemaker Cluster Manager: [FAILED]
> You're running on Heartbeat. The "pacemaker" init script manages the
> Pacemaker Master Control Process, which is only available/useful when
> Pacemaker runs on top of Corosync.
> You do not need to start the Pacemaker init script, nor the
> pacemakerd
> binary. Pacemaker's processes will simply run as children of
> Heartbeat. Thus, the failure to start pacemakerd would be unrelated
> to
> your original issue.
> Cheers,
> Florian
> --
> Need help with High Availability?
> http://www.hastexo.com/now

I just encountered the same kind of problem with my cluster setup on Friday (which is also Ubuntu 10.04 updated to the latest HA PPA packages).  Shell hung trying to add primitive - Ctrl-C to quit.  Then tried status - that worked fine.  Then ra info ocf:heartbeat:IPaddr2 - that hung.  Tried to restart one of the nodes - that hung with wating for crmd to quit for over 6 hours before I kill -9 crmd process.  That happened on both nodes.  The shell is still acting the same way after rebooting too.  

Pouring through logs trying to figure out what's going wrong! (at least this is still a test cluster)


More information about the Pacemaker mailing list