[Pacemaker] Proposed configuration change

Lars Marowsky-Bree lmb at suse.de
Mon Aug 4 06:08:58 EDT 2008

On 2008-08-04T11:00:36, Andrew Beekhof <abeekhof at suse.de> wrote:

> At the moment we have meta_attributes and instance_attributes options which 
> both contain "nvpairs".
> Would people consider it preferable if instead of nvpair objects, these 
> sets contained something that hinted at their purpose?
> What if we called the things in meta_attributes "options" (ie. <option 
> name= value=/>) and the ones in instance_attributes "parameters" (ie. 
> <parameter name= value=/>)?

I don't much like this. They are already contained within different
elements, so the elment hierarchy supplies this information.

And attributes containing options, no, parameters? That is not making
things clearer at all! This introduces additional terminology confusion,
after we have finally gotten people to think in meta attributes versus
"plain" attributes.

It makes sense to me that, everywhere where we use a attribute/value
list, we have nvpair elements. Reuse good.

> Would that make it clearer where things should be set?

I don't think so.

> In theory it would also allow us to enumerate the full set of options (such 
> as target-role, clone-max) and complain if an unknown one was specified.

You can already complain, but you can't make it a hard failure anyway,
as this might be something either from or for an older version.

Enumerating this is possible in the same way as with resource-level


Teamlead Kernel, SuSE Labs, Research and Development
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
"Experience is the name everyone gives to their mistakes." -- Oscar Wilde

More information about the Pacemaker mailing list