[Pacemaker] Proposed configuration change

Andrew Beekhof abeekhof at suse.de
Mon Aug 4 05:00:36 EDT 2008

At the moment we have meta_attributes and instance_attributes options  
which both contain "nvpairs".

Would people consider it preferable if instead of nvpair objects,  
these sets contained something that hinted at their purpose?
What if we called the things in meta_attributes "options" (ie. <option  
name= value=/>) and the ones in instance_attributes "parameters" (ie.  
<parameter name= value=/>)?

Would that make it clearer where things should be set?

In theory it would also allow us to enumerate the full set of options  
(such as target-role, clone-max) and complain if an unknown one was  

More information about the Pacemaker mailing list