[Pacemaker] pacemaker shutdown issue after OS change

Pascal BERTON pascal.berton3 at free.fr
Thu Jan 30 11:18:11 EST 2014

Hi !


I recently changed hosting platform versions for my PCMK clusters, from
RHEL6.0 equivalent towards SL6.4. Also changed from pcmk 1.1.2+corosync
1.3.3  to pcmk 1.1.10+corosync 1.4.1 that come with SL6.

Until now, I used to manage my pcmk+corosync layers directly from my own
personal init scripts, so I used to globaly disable pacemaker using
chkconfig. It was my scripts duty to start up cluster layer at boot and stop
it at node shutdown. And it has all worked fine for a couple of years !

With that new platform, I now see something odd at node shutdown : Although
both pacemaker and corosync services are disabled for every runlevel (And
BTW if I disable my own service, they won't start at boot), I can see that
pacemaker's init script is called as soon as I run the shutdown -r command.

After digging into what's happening inside, I can clearly see that although
disabled, pacemaker is still called immediately, does its job of stopping
the cluster and the related resources, and then when my own script runs (1st
in the shutdown script list) and tries to interract with the cluster layer,
too late, it has already died and its actions are not managed correctly.


I can workaround that by integrating my own shutdown sequence directly
within pacemaker init script, but I'd prefer making things cleaner by
maintaining them separate.


Is this behavior something expected (Or is it me ? 'Wouldn't be the first
time. :) )? What launches that disabled script ? Can I change that ? 


Thanks for your help !







Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clusterlabs.org/pipermail/pacemaker/attachments/20140130/44143b77/attachment-0002.html>

More information about the Pacemaker mailing list