[Pacemaker] Maintenance Mode Pacemaker

Christian Gebler geblerchristian at googlemail.com
Thu Jan 10 16:36:10 EST 2013


today i recognized a strange Pacemaker behavior at one of my
I needed to do some work on the services so i just wanted to prevent the
services from migrating to the other node and switched Pacemaker into the
maintenance mode:

# crm configure property maintenance-mode=true

After my work was done, i switched it back with the "false" value.

Now i wanted to test Pacemaker and killed one of my services.
But Pacemaker didn't recognized it and migrate nothing...the service was
still listed as "Running", i tried it with two other services on the node,
but the same result. The service was not listed in the process-list and the
initscript-status returned a false value,, so the service was really dead.
It looked like Pacemaker was still in maintenance mode, but it wasn't. In
the crm-config the maintenance mode was set as "false".

After a restart of Pacemaker and Corosync it works fine (restart or
migration of service).

Now i switched back to maintenance mode again, and turned it off again.
Same result...Pacemaker recognize nothing.

Now my question....is this how the maintenance mode should work and i
misunderstood something? ;) Or is it a bug or something else?

I use the ubuntu-server 12.04 LTS version, with updated Packages.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clusterlabs.org/pipermail/pacemaker/attachments/20130110/083b209a/attachment-0002.html>

More information about the Pacemaker mailing list