[Pacemaker] catch-22: can't fence node A because node A has the fencing resource

Lars Marowsky-Bree lmb at suse.com
Wed Dec 4 05:17:17 EST 2013

On 2013-12-03T19:47:41, "Brian J. Murrell" <brian at interlinx.bc.ca> wrote:

> So given all of the above, and given the log I supplied showing that the
> fencing was just not being attempted anywhere other than the node to be
> fenced (which was down during that log) any clues as to where to look
> for why?

As far as I saw in your logs, you got a timeout (when host2 tried to
fence host1). That doesn't seem to be related to this change.

> It explains the differences, but unfortunately I'm still not sure why it
> wouldn't get run somewhere else, eventually, rather than continually
> being attempted on the node to be killed (which as I mentioned, was shut
> down at the time the log was made).

I think there was a fix related to this in post-1.1.10 git. Perhaps you
can try that?


(For the record, this change in semantics and behaviour has caused quite
some support questions here too. I didn't really like it either, but
apparently, I'm just a whiner ;-)

Architect Storage/HA
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284 (AG Nürnberg)
"Experience is the name everyone gives to their mistakes." -- Oscar Wilde

More information about the Pacemaker mailing list