[Pacemaker] won't join cluster

Andrew Beekhof andrew at beekhof.net
Sun Sep 30 19:27:39 EDT 2012

On Mon, Oct 1, 2012 at 1:08 AM, James Harper
<james.harper at bendigoit.com.au> wrote:
> I just tried to join two machines to a cluster that were previously members of another cluster. One worked fine, but the other seems to have some problems. "crm status" says everything is offline, but the other nodes all see it as online and resources actually seem to start. It seems to say this a lot:
> ERROR: cib_perform_op: Discarding update with feature set '3.0.6' greater than our own '3.0.5'
> But there are other errors too (I'd have to sanitise the logs but can post if it would help)

They usually do.

> Have I got a mismatched version or something?

It looks like it based on that one log.  But its hard to be definitive
without any other information.

> Failing that, how do I clean out all the cluster configuration (cib etc) so it's like it's been just installed and can start from scratch?

On the node with the 'bad' or 'old' config, shut down pacemaker and run:

   rm -f /var/lib/heartbeat/crm/cib.*

> Everything is 1.1.7.
> Thanks
> James
> _______________________________________________
> Pacemaker mailing list: Pacemaker at oss.clusterlabs.org
> http://oss.clusterlabs.org/mailman/listinfo/pacemaker
> Project Home: http://www.clusterlabs.org
> Getting started: http://www.clusterlabs.org/doc/Cluster_from_Scratch.pdf
> Bugs: http://bugs.clusterlabs.org

More information about the Pacemaker mailing list