[Pacemaker] Cannot Create Primitive in CRM Shell

Andrew Martin amartin at xes-inc.com
Fri Jan 6 16:24:51 EST 2012


I am working with DRBD + Heartbeat + Pacemaker to create a 2-node highly-available cluster. I have been following this official guide on DRBD's website for configuring all of the components: 

However, once I go to configure the primitives in pacemaker's CRM shell (section 4.1 in the PDF above) I am unable to create the primitive. For example, I enter the following configuration for a DRBD device called "drive": 

primitive p_drbd_drive \ 
ocf:linbit:drbd \ 
params drbd_resource="drive" \ 
op monitor interval="15" role="Master" \ 
op monitor interval="30" role="Slave" 

After entering all of these lines I hit enter and nothing is returned - it appears frozen and I am never returned to the "crm(live)configure# " shell. An strace of the process does not reveal any obvious blocks. I have also tried entering the entire configuration on a single line with the same result. 

What can I try to debug this and move forward with configuring pacemaker? Is there a command I can use to completely clear out pacemaker to perhaps start fresh? 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clusterlabs.org/pipermail/pacemaker/attachments/20120106/0c082038/attachment-0002.html>

More information about the Pacemaker mailing list