[Pacemaker] How to run heartbeat and pacemaker resources as a non-root user

Andrew Beekhof andrew at beekhof.net
Mon Feb 20 06:05:30 EST 2012

On Mon, Feb 20, 2012 at 2:39 PM, neha chatrath <nehachatrath at gmail.com> wrote:
> Hello,
> I need to run heartbeat and pacemaker resources as non-root users.
> When I try to run heartbeat as a "hacluster" user,

That probably wont work.  We already try to drop as much privilege as
we can, but some processes need to be root or that can't do anything -
like add an IP address to a machine.

> it fails to run with the
> following error:
> "Starting High-Availability services: chmod: changing permissions of
> `/var/run/heartbeat/rsctmp': Operation not permitted
> Done. touch: cannot touch `/var/lock/subsys/heartbeat': Permission denied"
> I have tried changing ownership and permissions for the above directories
> and files but still the same result.
> Can somebody help me in this?
> Thanks and regards
> Neha Chatrath
> _______________________________________________
> Pacemaker mailing list: Pacemaker at oss.clusterlabs.org
> http://oss.clusterlabs.org/mailman/listinfo/pacemaker
> Project Home: http://www.clusterlabs.org
> Getting started: http://www.clusterlabs.org/doc/Cluster_from_Scratch.pdf
> Bugs: http://bugs.clusterlabs.org

More information about the Pacemaker mailing list