[Pacemaker] No resource failback with no stickiness - why ?

Sébastien ROHAUT sebastien.rohaut at free.fr
Sat Feb 18 09:15:31 EST 2012


I'm using Pacemaker 1.1.6 and corosync 1.4.2 under Fedora Core 16, using 
default rpms from repositories.

I'm trying to get a working Pacemaker cluster and I'm testing it by 
creating the "cluster from cratch configuration" from

I already worked with pacemaker 1.0.x two years ago, and it worked well 
(with the older documentation).

I'm encountering a problem. I added my IPAddr resource and tried 
failvover/failback. So I stop my first node, and my resource moves to 
node2. After a minute I restart node1, but my resource doesn't come 
back, my resource stays on node2.

As explained page 49, my resource should go back to node1. I didn't 
apply any stickiness value to my resource or in rsc_default. Did the 
behavior changed in this release ?

How to make it working ?

Thanks for your help.


ptest result :
# ptest -sL
Allocation scores:
native_color: apacheIP allocation score on node1: 0
native_color: apacheIP allocation score on node2: 0

Here is my actual conf :
# crm configure show
node node1
node node2
primitive apacheIP ocf:heartbeat:IPaddr \
         params ip="" cidr_netmask="32" nic="eth0" \
         op monitor interval="30s" \
         meta target-role="Started"
property $id="cib-bootstrap-options" \
dc-version="1.1.6-4.fc16-89678d4947c5bd466e2f31acd58ea4e1edb854d5" \
         cluster-infrastructure="openais" \
         expected-quorum-votes="2" \
         stonith-enabled="false" \

In XML :
# crm configure show xml
<?xml version="1.0" ?>
<cib admin_epoch="0" cib-last-written="Sat Feb 18 13:10:33 2012" 
crm_feature_set="3.0.5" dc-uuid="node1" epoch="34" have-quorum="1" 
num_updates="87" update-client="cibadmin" update-origin="node1" 
<cluster_property_set id="cib-bootstrap-options">
<nvpair id="cib-bootstrap-options-dc-version" name="dc-version" 
<nvpair id="cib-bootstrap-options-cluster-infrastructure" 
name="cluster-infrastructure" value="openais"/>
<nvpair id="cib-bootstrap-options-expected-quorum-votes" 
name="expected-quorum-votes" value="2"/>
<nvpair id="cib-bootstrap-options-stonith-enabled" 
name="stonith-enabled" value="false"/>
<nvpair id="cib-bootstrap-options-no-quorum-policy" 
name="no-quorum-policy" value="ignore"/>
<node id="node1" type="normal" uname="node1"/>
<node id="node2" type="normal" uname="node2"/>
<primitive class="ocf" id="apacheIP" provider="heartbeat" type="IPaddr">
<instance_attributes id="apacheIP-instance_attributes">
<nvpair id="apacheIP-instance_attributes-ip" name="ip" 
<nvpair id="apacheIP-instance_attributes-cidr_netmask" 
name="cidr_netmask" value="32"/>
<nvpair id="apacheIP-instance_attributes-nic" name="nic" value="eth0"/>
<op id="apacheIP-monitor-30s" interval="30s" name="monitor"/>
<meta_attributes id="apacheIP-meta_attributes">
<nvpair id="apacheIP-meta_attributes-target-role" name="target-role" 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clusterlabs.org/pipermail/pacemaker/attachments/20120218/c340fbb4/attachment-0002.html>

More information about the Pacemaker mailing list