[Pacemaker] Pacemaker fails to transition single node master/slave resource to master

Andrew Beekhof andrew at beekhof.net
Tue Aug 28 02:22:14 EDT 2012

On Mon, Aug 27, 2012 at 1:44 AM, Eliot Gable <egable+pacemaker at gmail.com> wrote:
> On Sun, Aug 26, 2012 at 11:31 AM, Eliot Gable <egable+pacemaker at gmail.com>
> wrote:
>> I have also tried doing a resource cleanup on FreeSWITCH-MS, restarting
>> pacemaker and corosync, putting the node in standby and bringing it back
>> out, upgrading pacemaker and corosync (to the version you seen in the output
>> in this E-mail from 1.1.6 previously where it first started happening) and
>> also completely wiping out everything in the /var/lib/corosync,
>> /var/lib/heartbeat, etc directories and recreating the entire config from
>> scratch (which, incidentally, DID clear up a warning I was getting about a
>> bad UUID), but nothing I have tried has resolved it. The odd thing is, this
>> single-node setup has been working for nearly a year with this exact
>> configuration. The box was rebooted last week, and now it just seems to sit
>> there playing dead.
> Looking back through my E-mails, it looks like this was originally deployed
> on 1.1.2. My guess is that someone did a sweeping software update on the
> system but never restarted/reloaded pacemaker + corosync until that reboot
> occurred last week. Did something change between 1.1.2 and 1.1.6 which might
> have broken how the system behaves in the scenario I outlined?

This would be my guess:

+ Andrew Beekhof (1 year, 7 months ago) 671fc71: High: PE: Bug lf#2554
- target-role alone is not sufficient to promote resources

More information about the Pacemaker mailing list