[Pacemaker] Using Cluster Test Suite (CTS) with "debug: on" in corosync.conf failed

Andrew Beekhof andrew at beekhof.net
Mon Apr 16 21:12:24 EDT 2012

On Fri, Apr 13, 2012 at 11:26 PM, Timo Schäpe <schaepe at dfn-cert.de> wrote:
> Am 10.04.2012 23:43, schrieb Andrew Beekhof:
>> On Tue, Apr 10, 2012 at 11:05 PM, Timo Schäpe <schaepe at dfn-cert.de> wrote:
>>> Hi,
>>> for whom it may interest, here's something that cost me a whole day of work:
>>> I used CTS to test my cluster configuration and it worked fine. For
>>> debugging a resource agent I switched on the debug output in corosync.conf:
>>> logging {
>>>        [...]
>>>        debug: on
>>>        [...]
>>> }
>>> After I fixed the bug, I forgot to switch debug output off. This caused
>>> most of the CTS tests to fail with this warning:
>>> CTS: Warn: Startup pattern not found: myhost crmd:.*The local CRM is
>>> operational
>>> After I switched debug output off, the CTS worked fine as before.
>> We've since added a BadNews pattern that looks for syslog messages
>> being dropped/throttled.
>> How was your experience with CTS otherwise?
>> Periodically I try to improve the usability so that eventually
>> non-developers can use it, it would be interesting to hear how we're
>> doing.
> It was easy for me to work with CTS. I read about the basics of CTS in
> the book of Michael Schwartzkopff (Clusterbau). Some deeper information
> about the configuration I got from the README and that was enough to
> start some tests.
> What I missed is a short explanation of the tests and the meaning of
> their failures. For example my cluster fails completly at the
> ResourceRecover and Reattach tests. But unfortunately I only know the
> meaning of the ResourceRecover test, because there is an explanation in
> the Schwartzkopff book. Maybe there is an online resource that I had
> overlooked till now.

There is http://www.clusterlabs.org/wiki/ReleaseTesting#List_of_Automated_Test_Cases
But its all but impossible to describe the failures as that would be a
list of every possible bug - basically there shouldn't be any

> And I am not sure, how I can test a cluster with STONITH resources with
> the CTS. Should I use the stonith-ssh?

As Dejan mentioned, you can (and should) use whichever stonith device
you would normally define.
Are you having CTS create a configuration or using the one you plan to
use in production?

More information about the Pacemaker mailing list