[Pacemaker] Using Cluster Test Suite (CTS) with "debug: on" in corosync.conf failed

Timo Schäpe schaepe at dfn-cert.de
Tue Apr 10 09:05:37 EDT 2012

for whom it may interest, here's something that cost me a whole day of work:

I used CTS to test my cluster configuration and it worked fine. For
debugging a resource agent I switched on the debug output in corosync.conf:

logging {
        debug: on

After I fixed the bug, I forgot to switch debug output off. This caused
most of the CTS tests to fail with this warning:

CTS: Warn: Startup pattern not found: myhost crmd:.*The local CRM is

After I switched debug output off, the CTS worked fine as before.



Dipl.-Inf. Timo Schaepe                     (Projekt- u. Entwicklungsteam)
Phone:+49 40 808077-650   Fax:+49 40 808077556    Mail:schaepe at dfn-cert.de

DFN-CERT Services GmbH, https://www.dfn-cert.de/, Phone  +49 40 808077-555
Sitz / Register: Hamburg, AG Hamburg, HRB 88805,  Ust-IdNr.:  DE 232129737
Sachsenstrasse 5, 20097 Hamburg, Germany. CEO: Dr. Klaus-Peter Kossakowski

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5901 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.clusterlabs.org/pipermail/pacemaker/attachments/20120410/9e500d3e/attachment-0002.p7s>

More information about the Pacemaker mailing list