[Pacemaker] Pure-FTPd resource script is wrong (at least on ubuntu and probably debian)

Frank Lazzarini flazzarini at gmail.com
Sun Nov 13 13:47:53 EST 2011

Hi all,

I actually read this thread earlier this week on my phone and I wanted 
to answer about this more general problem. I ran into problems with this 
when I was trying to get openvpn to work in pacemaker once, and I solved 
this problem otherwise. Since then I always chose this solution, so I 
wouldn't have to change anything on the resource agents or so on, but I 
don't know if it is really an acceptable way of solving this. Anyways 
here is what I do, let's say you need to have /var/run/mysql for your 
service to work, what I do I just add a cronjob which creates that 
directory which the propper permissions every bootup which should be 
fine enough.


@reboot    root   [ -d /var/run/mysqld ] || install -m 755 -o mysql -g 
root -d /var/run/mysqld

something similar can be done for other services like for instance pureftpd.

Hope that helps! :)

On 11/13/2011 07:33 PM, Raoul Bhatia [IPAX] wrote:
> hi racke!
> hi nicola!
> On 12.11.2011 14:07, Mailing List SVR wrote:
>>> So the proposed changes for Debian package are:
>>> * move directory creation into wrapper script
>>> * make location of PID file configurable
>>> Please comment if I got that right.
>> yes that would be another good solution,
> imho, this is correct.
> thanks,
> raoul
> _______________________________________________
> Pacemaker mailing list: Pacemaker at oss.clusterlabs.org
> http://oss.clusterlabs.org/mailman/listinfo/pacemaker
> Project Home: http://www.clusterlabs.org
> Getting started: http://www.clusterlabs.org/doc/Cluster_from_Scratch.pdf
> Bugs: 
> http://developerbugs.linux-foundation.org/enter_bug.cgi?product=Pacemaker

More information about the Pacemaker mailing list