[Pacemaker] Doc: Resource templates

Tim Serong tserong at suse.com
Wed Dec 14 02:39:46 EST 2011

On 12/14/2011 02:57 AM, Dejan Muhamedagic wrote:
> On Tue, Dec 13, 2011 at 04:18:33PM +0800, Gao,Yan wrote:
>> On 12/13/11 04:25, Andrew Beekhof wrote:
>>> On Mon, Dec 12, 2011 at 9:20 PM, Gao,Yan<ygao at suse.com>  wrote:
>>>> On 12/12/11 17:52, Florian Haas wrote:
>>>>> On Mon, Dec 12, 2011 at 10:36 AM, Gao,Yan<ygao at suse.com>  wrote:
>>>>>> On 12/12/11 17:16, Florian Haas wrote:
>>>>>>> On Mon, Dec 12, 2011 at 10:04 AM, Gao,Yan<ygao at suse.com>  wrote:
>>>>>>>> On 12/12/11 15:55, Gao,Yan wrote:
>>>>>>>>> Hi,
>>>>>>>>> As some people have noticed, we've provided a new feature "Resource
>>>>>>>>> templates" since pacemaker-1.1.6. I made a document about it which is
>>>>>>>>> meant to be included into "Pacemaker_Explained". I borrowed the
>>>>>>>>> materials from Tanja Roth , Thomas Schraitle, (-- the documentation
>>>>>>>>> specialists from SUSE) and Dejan Muhamedagic. Thanks to them!
>>>>>>>>> Attaching it here first. If you are interested, please help review it.
>>>>>>>>> And if anyone would like to help convert it into DocBook and made a
>>>>>>>>> patch, I would be much appreciate. :-)
>>>>>>>>> I can tell people would like to see a crm shell version of it as well.
>>>>>>>>> I'll sort it out and post it here soon.
>>>>>>>> Attached the crm shell version of the document.
>>>>>>> As much as I appreciate the new feature, was it really necessary that
>>>>>>> you re-used a term that already has a defined meaning in the shell?
>>>>>>> http://www.clusterlabs.org/doc/crm_cli.html#_templates
>>>>>>> Couldn't you have called them "resource prototypes" instead? We've
>>>>>>> already confused users enough in the past.
>>>>>> Since Dejan adopted the object name "rsc_template" in crm shell, and
>>>>>> call it "Resource template" in the help. I'm not inclined to use another
>>>>>> term in the document. Opinion, Dejan?
>>>>> I didn't mean to suggest to use a term in the documentation that's
>>>>> different from the one the shell uses. I am suggesting to rename the
>>>>> feature altogether. Granted, it may be a bit late to have a naming
>>>>> discussion now, but I haven't seen this feature discussed on the list
>>>>> at all, so there wasn't really a chance to voice these concerns
>>>>> sooner.
>>>> Actually there were discussions in pcmk-devel mailing list. Given that
>>>> it has been included into "pacemaker-1.2" schema and released with
>>>> pacemaker-1.1.6, it seems too late for us to change it from cib side
>>>> now
>>> Technically its not yet in the 1.2 area, that change was pending on
>>> this documentation update.
>> OK then. I would like to hear more voices about that, since Dejan and
>> Tim have been working on this for quite some time too.
> Well, I believe that we already discussed the name. And there
> were no better ideas heard. But it could as well be that my
> memory fails me.

I don't recall any better naming ideas floating past either (although, 
now that Florian mentions "prototype", hmm...)

Anyway, IMO, overloading the word "template" isn't /too/ bad.  It could 
be qualified if necessary as "resource template" (the new feature we're 
talking about here) and "configuration template" (existing shell feature)...


Tim Serong
Senior Clustering Engineer
tserong at suse.com

More information about the Pacemaker mailing list