[Pacemaker] Antwort: IPaddr2 resource IP unavailable on 'lo' interface for brief period after start

Patrick H. pacemaker at feystorm.net
Tue Aug 30 10:51:02 EDT 2011

Sent: Mon Aug 29 2011 02:50:33 GMT-0600 (MST)
From: alexander.krauth at basf.com
To: The Pacemaker cluster resource manager <pacemaker at oss.clusterlabs.org>
Subject: [Pacemaker] Antwort: IPaddr2 resource IP unavailable on 'lo' 
interface for brief period after start
> "Patrick H."<pacemaker at feystorm.net>  schrieb am 27.08.2011 10:22:08:
>> [Pacemaker] IPaddr2 resource IP unavailable on 'lo' interface for brief
> period after start
>> So the issue is that whenever I start up an IP with an IPaddr2 resource,
> the IP is unavailable when attempting to connect via lo interface for
> approximately 21 seconds after the resource is started.
>> What I am doing is starting up the IP resource, and then I have another
> resource that tries to start, but prior to starting it does a status check
> by connecting to that IP on a TCP port to see if
>> the service is up. And if it isnt up, then it starts it. Well I should
> immediately get a 'connection refused' message as the service isnt
> running, however I dont. Instead the resource times out as I
>> have startup timeout set to 20 seconds, and connection attempts wont
> give 'connection refused' until after 21 seconds. However I can try to
> connect from another host on the network and I immediately
>> get 'connection refused' as expected, even while the box trying to
> connect to itself is still not working.
>> But it gets even more interesting. I did a tcpdump on eth0 interface
> (the interface the IPaddr2 resource IP is on) the box running the
> resources and I get the following when resources start up
>> (presumably triggered by the box trying to connect for the status
> check):
>>    01:12:21.423330 arp who-has (Broadcast) tell
>>    01:12:22.428523 arp who-has (Broadcast) tell
>>    01:12:23.429342 arp who-has (Broadcast) tell
>> Notice as my box seems to be having a slight identity crisis
> ( is the IPaddr2 resource)
>> Also when I tcpdump on the lo interface I get the following
>>    01:15:41.837719 IP> S
> 1770941237:1770941237(0) win 32792<mss 16396,sackOK,timestamp 190131056
> 0,nop,wscale 4>
>>    01:15:44.845531 IP> S
> 1770941237:1770941237(0) win 32792<mss 16396,sackOK,timestamp 190134064
> 0,nop,wscale 4>
>> Which indicates that the box clearly isnt responding ( is
> the box's normal ip)
>> As mentioned earlier, after 21 seconds I start getting 'connection
> refused' when attempting to connect. The packets are still going over the
> lo interface at this point, so nothing changes.
>> Additionally an arp reply never does come back on eth0 or lo, it just
> magically starts working.
>> I could bump up my timeout to something higher, but i would really
> prefer to get this issue
> solved._______________________________________________
> Hm, just an idea. Did you try:
> ip route flush cache
> There is also the "flush_routes" parameter in ipaddr2, but this is only in
> the "stop" method. Seams your issue is somehow different.
> Regards
> Alex

Tried `ip route flush cache`, had no effect.

And I realized the weird arps in the tcpdump output were the unsolicited 
arps sent by IPaddr2 when the interface comes up. Was expecting to see 
arp announces, not queries :-)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clusterlabs.org/pipermail/pacemaker/attachments/20110830/19eff640/attachment-0003.html>

More information about the Pacemaker mailing list