[Pacemaker] [PATCH]Bug 2567 - crm resource migrate should support an optional "role" parameter

Andrew Beekhof andrew at beekhof.net
Thu Apr 7 02:57:18 EDT 2011

On Wed, Apr 6, 2011 at 3:38 PM, Dejan Muhamedagic <dejanmm at fastmail.fm> wrote:
> On Wed, Apr 06, 2011 at 01:00:36PM +0200, Andrew Beekhof wrote:
>> On Tue, Apr 5, 2011 at 12:27 PM, Dejan Muhamedagic <dejanmm at fastmail.fm> wrote:
>> > Ah, right, sorry, wanted to ask about the difference between
>> > move-off and move. The description looks the same as for move. Is
>> > it that in this case it is for clones so crm_resource needs an
>> > extra node parameter? You wrote in the doc:
>> >
>> >        +Migrate a resource (-instance for clones/masters) off the specified node.
>> >
>> > The '-instance' looks somewhat funny. Why not say "Move/migrate a
>> > clone or master/slave instance away from the specified node"?
>> >
>> > I must say that I still find all this quite confusing, i.e. now
>> > we have "move", "unmove", and "move-off", but it's probably just me :)
>> Not just you.  The problem is that we didn't fully understand all the
>> use case permutations at the time.
>> I think, not withstanding legacy computability, "move" should probably
>> be renamed to "move-to" and this new option be called "move-from".
>> That seems more obvious and syntactically consistent with the rest of
>> the system.
> Yes, move-to and move-from seem more consistent than other
> options. The problem is that the old "move" is at times one and
> then at times another.

Thats ok, we can make the compat code work as expected.

>> In the absence of a host name, each uses the current location for the
>> named group/primitive resource and complains for clones.
>> The biggest question in my mind is what to call "unmove"...
>> "move-cleanup" perhaps?
> move-remove? :D
> Actually, though the word is a bit awkward, unmove sounds fine
> to me.

I think the challenge with unmove is that it appears to imply that the
resource will move back - when in fact it just arranges things so that
it could.
So move-remove and move-cleanup get the user thinking in the right direction.

More information about the Pacemaker mailing list