[Pacemaker] [PATCH]Bug 2567 - crm resource migrate should support an optional "role" parameter

Andrew Beekhof andrew at beekhof.net
Wed Apr 6 07:00:36 EDT 2011

On Tue, Apr 5, 2011 at 12:27 PM, Dejan Muhamedagic <dejanmm at fastmail.fm> wrote:
> Ah, right, sorry, wanted to ask about the difference between
> move-off and move. The description looks the same as for move. Is
> it that in this case it is for clones so crm_resource needs an
> extra node parameter? You wrote in the doc:
>        +Migrate a resource (-instance for clones/masters) off the specified node.
> The '-instance' looks somewhat funny. Why not say "Move/migrate a
> clone or master/slave instance away from the specified node"?
> I must say that I still find all this quite confusing, i.e. now
> we have "move", "unmove", and "move-off", but it's probably just me :)

Not just you.  The problem is that we didn't fully understand all the
use case permutations at the time.

I think, not withstanding legacy computability, "move" should probably
be renamed to "move-to" and this new option be called "move-from".
That seems more obvious and syntactically consistent with the rest of
the system.

In the absence of a host name, each uses the current location for the
named group/primitive resource and complains for clones.

The biggest question in my mind is what to call "unmove"...
"move-cleanup" perhaps?

More information about the Pacemaker mailing list